Home Forums Ademco Technical Questions Ademco Vista-10P New Install problem

This topic contains 2 replies, has 2 voices, and was last updated by  bass1702 2 years, 11 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #13755


    Ok all,  here is the scoop and I am stumped on this:

    Brand New Items:

    -Honeywell/Ademco Vista 10P Control Panel
    -honeywell 6150RF Keypad
    -5 5816 Door/Window Sensors
    -1 5894PI Motion
    -1 7845GSM Cellular Communicator

    Here is the problem.  I connected all wires (including the GSM) and then powered the system on for the first time.  The keypad beeps and lights up, but the screen is blank…no words what so ever.  I checked the Keypad Address and tried all address from 00-31 and none of them worked.  I got my 6139 Alpha Keypad and connected it and same damn thing.

    The GSM is connected to the keypad terminals, as instructed in the manual.  However, the GSM is not Registered, Activated or anything.  but it is connected. 

    Why cant I get into programming?  Why are the screens on both keypads completely blank?  Whats up with this?  Thoughts….Solutions.  All welcome.  Please someone help ASAP as I have to have this system done and functioning by tomorrow evening.

    Thanks all!



    You have to address the 6150rf keypad as address 16. To do that power up the keypad and hold down buttons 1 & 3. Then press 1 16 * ##. This should get the keypad on.
    Once you get the keypad on you can get into programming and activate keypad address 17 and assign the other keypad to it.



    It was the address problem.  I dont know WHY I didnt think of that!!!!!  Of course, I had just worked a 16 hour shift at my full time job and went from there to the client to install this system, so I was pretty out of it.  But still did a damn good job and its now up n running perfectly.   :)   Thanks for that!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.