Home Forums DSC Technical Questions Alexor won’t connect to DLS-IV

This topic contains 6 replies, has 2 voices, and was last updated by  greenbird 3 years, 6 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #11971

    greenbird
    Member

    Hey guys,

    I'm trying to connect an Alexor PC9155CP-01 with v1.10 firmware, but no matter what I try (Global Upload, Global Download, specific tags, etc.), I can't get it to connect to DLS-IV. Punching in <499> <installer code> <499> doesn't make a difference either.  :'(

    I've got the cable properly wired up as far as I can tell:

    PC-Link      DB9
       <1> <–> <3>
       <2> <–> <5> ground
       <3> <–> <5> ground
       <4> <–> <2>
    < "Red"> <–> no connection
            /–> <4>
      jumper
           \–> <6>

    At first, I thought my USB converter was the problem, but I'm now running it on another PC with a built-in serial-port and I'm having the exact same issue.

    For software, I am running the latest NA version of DLS-IV, 1.3.1009.27001, downloaded through the automatic updater.

    I confirmed that the serial hook-up is passing data because if I put the PC-Link connector into GPRS/Ethernet mode (<382><5>), I can see some data being sent by the Alexor every second. Nothing shows up if I reverse the serial cable.

    Anybody know what I'm doing wrong?  ???

    Thanks,

    Victor

    #53972

    Old EW Tech
    Keymaster

    Just from memory, your diagram doesn't look right.

    The forum's search feature should bring one up for you to compare (try "PC-Link pin out", "PC-Link diagram", etc for search terms and restrict search to DSC Forum). 

    #53974

    greenbird
    Member

    Thanks for the hint, Old EW.

    Here's the most relevant post I found in the forums:

    http://www.diyalarmforum.com/board/index.php?topic=15.0

    The two wirings look the same to me, except for the question of pin outs on the Alexor's PC-Link.

    One pin is very clearly labeled as "Red", which I call pin 5:

    |
    |
    |
    |
      "Red"

    The | indicates the white bar on the PCB's silk screening to show where the DSC PC-Link cable should go / orientation.

    So the question (especailly for Alexor users) is: What are the pin assignments for pins 1-5? I believe 2 and 3 are grounds and 5 ("Red") is a +16.5V power source.

    Has anybody been able to successfully connect the Alexor PC9155 to DLS-IV? If so, can you provide a walk-through on how to get it wired and connected properly?

    Thanks!

    Victor

    #53977

    Old EW Tech
    Keymaster

    Of course.

    The standard 4-pin PC-Link cable will work on the Alexor (using the top 4 pins).

    If you're having difficulty connecting and are unsure of the cable, why not buy the PC-Link cable and eliminate a variable?

    #53980

    greenbird
    Member

    Good point. I'll buck up and spend the extra few bucks. Normally I'm pretty good at wiring things up, but in this case, who knows. I'll report back if the cable from DSC solves my problem.

    Thanks for the sound advice, Old EW.

    Cheers,

    Victor

    #53982

    Old EW Tech
    Keymaster

    That's the spirit.  :)

    If you have any problem with the "store-bought", we'll do our best to get you up and running.

    #54098

    greenbird
    Member

    Found the solution to my problem… and it may surprise you…

    THE SERIAL PORT! For whatever reason, a REAL DB9 RS-232 serial port on an Intel motherboard would not connect to the PC9155, but using a Keyspan USA-19HS USB-serial converter worked.  :o

    This confirms that the wiring of my "home-brewed" cable is fine and no, the "Red" pin is not used when connecting via DLS IV.

    Thanks again to Old EW Tech for the pointers.

    Cheers,

    Victor

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.