Home Forums DSC Technical Questions DSC pc1616 Bell Circuit Trouble

This topic contains 6 replies, has 4 voices, and was last updated by  acorona 1 year, 4 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #16829

    Lukeup
    Member

    Hi, I have a DSC pc1616. I'm making my way through most of the programming. I enter *2 and I have a 1 showing. When I press 1 my pk5501 beeps (2 times) and shows a 2. According to the user guide I believe this means a Bell Circuit Trouble. When I hook up the siren, it just blares. I read somewhere to hook up a 1k resistor if it not used. I have done this.

    Does anyone know how I can clear this trouble??  I completed a factory reset, reprogrammed master code, installer code, turned off telephone line monitor, etc.  Not sure what else to do to get the siren from sounding.  The pc1616 is not armed.  I have a green check and yellow or orange triangle.

    Appreciate your time, Luke.

    #70609

    blakem
    Participant

    The trouble will go away automatically when you attach the siren or resistor.  It is reporting an open on the bell circuit.  Attach the 1k resitor on the bell circuit and the trouble should go away.  Then try and attach your siren again while leaving the resistor still attached.  I believe with the resistor on there it will take care of the small supervision current that is making you siren sound.

    #70637

    Lukeup
    Member

    Hi, it hasn't cleared.  I left the resistor on and touched the siren leads and it is still blaring.  It looks like there is nearly 18 volts across the bell contacts.  I was hoping I did not have a failed pc1616 board…..  any other suggestions??  Appreciate your time, Luke.

    #73097

    acorona
    Participant

    Hi Luke..  I have the same problem with mine… I did the same as you, reset it several times, hook a bulb.. And nothing.. The siren still sounding, any suggestion?? Did you get any answer for this?? anybody that c an help me?? Thanks.. alex

    #73102

    Lukeup
    Member

    Hey Alex, I haven't been able to get it.  I was going to call DSC to see if they had any advice.  I bought 2 in an auction on ebay and the 2nd seems to be working.  I left the resistor on for a couple days but the trouble never cleared, had to give up.  If I find something I’ll be sure to post it up.  Thanks, Luke.

    #73105

    dilligaff
    Participant

    Do you have any zones programmed as 24 hour zones??
    If you do this explains why your siren is sounding. To silence the siren enter your user code. Default user code is 1234.
    Most 24 hour  (except for supervisory and hold up) zones have the siren option turned on by default. If you don't want a 24 hr zone to sound the siren it is changed by turning option 1 off in programming section 1XX  ( XX= zone number ).

    #73265

    acorona
    Participant

    Too bad to hear that Luke.. I will keep looking for an answer…

    Dilligaff..  I don't have any 24 hr zone.. I tried deactivating option 1 in all my zones and even with that it stills sounding..

    I tried with a second Siren, bigger, and nothing… The same problem.  If i install the resistor 1 K, the small siren shut off but for ever.. Even with a violated zone it doesn't sound anymore.  Any suggestion??

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.