Home Forums Caddx Technical Questions Networx Series NX-148E Has No Power

This topic contains 1 reply, has 2 voices, and was last updated by  ABLE1 4 years, 2 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #10277

    agoodman82
    Participant

    Hi all,I'm a new home-owner and have had no prior experience with home alarm systems. The home I moved into has a Networx Series NX-148E LCD keypad which I left to "chime" whenever a protected zone entry-way (door, window...etc) was opened.A week ago, the keypad displayed a service message which indicated "Control Power Trouble" (description states "the main power to your system is not on". Initially I thought it was referring to the battery (a 12v lead-acid rechargeable battery) which I disconnected from a red + and a black - wire leading into the battery. When I did this, the LCD keypad completely shutoff. Plugging the battery back in did not change anything -- the system remained off.I figured the battery was dead so I ordered a new one of the same type. Once I got the replacement yesterday, I plugged it in and still no power to the system. Today I shut off all the breakers at my transformer after disconnecting the battery, waited a few minutes, then put the AC power back on and then plugged in the battery. There is still no power to my alarm system. Anyone have any ideas???

    #47395

    ABLE1
    Participant

    Hello and welcome to the Forum.

    From your description it would seem that the panel is not getting AC voltage.

    To verify you will need a Volt Meter.  You should have at least 16.5vac at the terminals marked AC.

    If you don't have or know how to use a Volt Meter you may want to contact a local alarm dealer.

    Good Luck

    ABLE1

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.